Configuring IP Unicast Routing
Router(config)# interface Loopback2
Router(config-if)# ip vrf forwarding v2
Router(config-if)# ip address 3.3.2.3 255.255.255.0
Router(config-if)# exit
Router(config)# interface gigabitethernet1/1/0.10
Router(config-if)# encapsulation dot1q 10
Router(config-if)# ip vrf forwarding v1
Router(config-if)# ip address 38.0.0.3 255.255.255.0
Router(config-if)# exit
Router(config)# interface gigabitethernet1/1/0.20
Router(config-if)# encapsulation dot1q 20
Router(config-if)# ip vrf forwarding v2
Router(config-if)# ip address 83.0.0.3 255.255.255.0
Router(config-if)# exit
Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf v2
Router(config-router-af)# neighbor 83.0.0.8 remote-as 800
Router(config-router-af)# neighbor 83.0.0.8 activate
Router(config-router-af)# network 3.3.2.0 mask 255.255.255.0
Router(config-router-af)# exit
Router(config-router)# address-family ipv4 vrf vl
Router(config-router-af)# neighbor 38.0.0.8 remote-as 800
Router(config-router-af)# neighbor 38.0.0.8 activate
Router(config-router-af)# network 3.3.1.0 mask 255.255.255.0
Router(config-router-af)# end
Configuring Unicast Reverse Path Forwarding
The unicast reverse path forwarding (unicast RPF) feature helps to mitigate problems that are caused by the
introduction of malformed or forged (spoofed) IP source addresses into a network by discarding IP packets
that lack a verifiable IP source address. For example, a number of common types of denial-of-service (DoS)
attacks, including Smurf and Tribal Flood Network (TFN), can take advantage of forged or rapidly changing
source IP addresses to allow attackers to thwart efforts to locate or filter the attacks. For Internet service
providers (ISPs) that provide public access, Unicast RPF deflects such attacks by forwarding only packets
that have source addresses that are valid and consistent with the IP routing table. This action protects the
network of the ISP, its customer, and the rest of the Internet.
Note
• Unicast RPF is supported in Network Essentials.
For detailed IP unicast RPF configuration information, see the Other Security Features chapter in the Cisco
IOS Security Configuration Guide.
Protocol-Independent Features
This section describes IP routing protocol-independent features that are available on switches running the
Network Essentials feature set . For a complete description of the IP routing protocol-independent commands
in this chapter, see the "IP Routing Protocol-Independent Commands" chapter of the Cisco IOS IP Command
Reference, Volume 2 of 3: Routing Protocols.
Routing Configuration Guide, Cisco IOS XE Everest 16.6.x (Catalyst 9500 Switches)
Configuring Unicast Reverse Path Forwarding
179
Need help?
Do you have a question about the Catalyst 9500 series and is the answer not in the manual?
Questions and answers