Cisco Catalyst 3750 Software Configuration Manual page 580

Metro switch
Hide thumbs Also See for Catalyst 3750:
Table of Contents

Advertisement

Configuring Hierarchical QoS
Command
Step 7
interface interface-id
Step 8
service-policy output policy-map-name
Step 9
end
Step 10
show policy-map [policy-map-name [class
class-map-name]]
or
show policy-map interface interface-id
Step 11
copy running-config startup-config
To delete an existing policy map, use the no policy-map policy-map-name global configuration
command. To delete an existing class, use the no class class-name policy-map configuration command.
To disable the average-rate traffic shaping, use the no shape average policy-map class configuration
command.
This example shows how to configure class-level, average-rate shaping. It limits traffic class class1 to a
data transmission rate of 256 kbps.
Switch(config)# class-map class1
Switch(config-cmap)# match cos 0 1 2 3
Switch(config-cmap)# exit
Switch(config)# policy-map policy1
Switch(config-pmap)# class class1
Switch(config-pmap-c)# shape average 256000
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# service-policy output policy1
This example shows how to configure VLAN-level, average-rate shaping. It limits each traffic class,
vlan101 and vlan102, to a data transmission rate of 400 Mbps.
Switch(config)# class-map match-all vlan101
Switch(config-cmap)# match vlan 101
Switch(config-cmap)# exit
Switch(config)# class-map match-all vlan102
Switch(config-cmap)# match vlan 102
Switch(config-cmap)# exit
Switch(config)# policy-map vlan-policy
Switch(config-pmap)# class vlan101
Switch(config-pmap-c)# shape average 400000000
Switch(config-pmap-c)# exit
Switch(config-pmap)# class vlan102
Switch(config-pmap-c)# shape average 400000000
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
Switch(config-if)# service-policy output vlan-policy
Catalyst 3750 Metro Switch Software Configuration Guide
26-100
Purpose
Specify an ES port to attach to the policy map, and enter interface
configuration mode.
Specify the egress policy-map name, and apply it to the ES port.
Only one policy map per port is supported.
Return to privileged EXEC mode.
Verify your entries.
(Optional) Save your entries in the configuration file.
Chapter 26
Configuring QoS
78-15870-01

Advertisement

Table of Contents
loading

Table of Contents