Cisco Catalyst 3750 Software Configuration Manual page 568

Metro switch
Hide thumbs Also See for Catalyst 3750:
Table of Contents

Advertisement

Chapter 26
Configuring QoS
Configuring Hierarchical QoS
This example shows how to create a class-level policy-map called policy11 for three classes called prec1,
prec2, and prec3. In the policy for these classes, 30 percent of the available bandwidth is assigned to the
queue for the first class, 20 percent is assigned to the queue for the second class, and 10 percent is
assigned to the queue for the third class. Tail drop is enabled on each class queue, packets are queued
until the maximum threshold of 2000 packets is exceeded, and then all the packets are dropped.
Switch(config)# class-map prec1
Switch(config-cmap)# match ip precedence 1
Switch(config-cmap)# exit
Switch(config)# class-map prec2
Switch(config-cmap)# match ip precedence 2
Switch(config-cmap)# exit
Switch(config)# class-map prec3
Switch(config-cmap)# match ip precedence 3
Switch(config-cmap)# exit
Switch(config)# policy-map policy11
Switch(config-pmap)# class prec1
Switch(config-pmap-c)# bandwidth percent 30
Switch(config-pmap-c)# queue-limit 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# class prec2
Switch(config-pmap-c)# bandwidth percent 20
Switch(config-pmap-c)# queue-limit 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# class prec3
Switch(config-pmap-c)# bandwidth percent 10
Switch(config-pmap-c)# queue-limit 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# service-policy output policy11
This example shows how to create a VLAN-level policy-map called vlan-policy for two classes called
vlan203 and vlan202. In the policy for these classes, the minimum bandwidth is set to 2000 kbps.
Switch(config)# class-map match-all vlan203
Switch(config-cmap)# match vlan 203
Switch(config-cmap)# match vlan inner 206
Switch(config-cmap)# exit
Switch(config)# class-map match-all vlan202
Switch(config-cmap)# match vlan 202
Switch(config-cmap)# match vlan inner 204
Switch(config-cmap)# exit
Switch(config)# policy-map vlan-policy
Switch(config-pmap)# class vlan203
Switch(config-pmap-c)# bandwidth 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# class vlan202
Switch(config-pmap-c)# bandwidth 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# service-policy output vlan-policy
Catalyst 3750 Metro Switch Software Configuration Guide
26-88
78-15870-01

Advertisement

Table of Contents
loading

Table of Contents