Cisco Catalyst 3750 Software Configuration Manual page 563

Metro switch
Hide thumbs Also See for Catalyst 3750:
Table of Contents

Advertisement

Chapter 26
Configuring QoS
Configuring Hierarchical QoS
This example shows how to configure a VLAN-level, two-rate traffic policer to limit outbound traffic to
an average committed rate of 500 kbps and a peak rate of 1 Mbps. Traffic marked as conforming to the
average committed rate (500 kbps) is sent as is. Traffic marked as exceeding 500 kbps, but not exceeding
1 Mbps, is marked with IP precedence 2 and then sent. All traffic marked as exceeding 1 Mbps is
dropped. The burst parameters are set to 10000 bytes.
Switch(config)# class-map match-all vlan203
Switch(config-cmap)# match vlan 203
Switch(config-cmap)# match vlan inner 206
Switch(config-cmap)# exit
Switch(config)# policy-map vlan-policy
Switch(config-pmap)# class vlan203
Switch(config-pmap-c)# police cir 500000 bc 10000 pir 1000000 be 10000 conform-action
transmit exceed-action set-prec-transmit 2 violate-action drop
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# service-policy output vlan-policy
This example shows how to create a hierarchical service-policy in which all levels are present. This
configuration associates a class-level policy-map with a VLAN-level policy-map, associates the
VLAN-level policy-map with a physical-level policy-map, and attaches the physical-level policy-map to
a physical port.
Within a policy map, the class-default applies to all traffic that is not explicitly matched within the policy
map but does match the parent policy. If no parent policy is configured, the parent policy represents the
physical port. In a physical-level policy-map, class-default is the only class that can be configured.
Switch(config)# class-map my-class
Switch(config-cmap)# match ip precedence 1
Switch(config-cmap)# exit
Switch(config)# class-map my-logical-class
Switch(config-cmap)# match vlan 5
Switch(config-cmap)# exit
Switch(config)# policy-map my-class-policy
Switch(config-pmap)# class my-class
Switch(config-pmap-c)# set ip precedence 2
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# policy-map my-logical-policy
Switch(config-pmap)# class my-logical-class
Switch(config-pmap-c)# service-policy my-class-policy
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# policy-map my-physical-policy
Switch(config-pmap)# class class-default
Switch(config-pmap-c)# police cir 500000 bc 10000 pir 1000000 be 10000 conform-action
transmit exceed-action set-prec-transmit 2 violate-action drop
Switch(config-pmap-c)# service-policy my-logical-policy
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/1
Switch(config)# service-policy output my-physical-policy
Catalyst 3750 Metro Switch Software Configuration Guide
26-83
78-15870-01

Advertisement

Table of Contents
loading

Table of Contents