Cisco Catalyst 3750 Software Configuration Manual page 576

Metro switch
Hide thumbs Also See for Catalyst 3750:
Table of Contents

Advertisement

Chapter 26
Configuring QoS
Configuring Hierarchical QoS
This example shows how to configure a class-level policy called policy10. Class c1 has these
characteristics: a minimum of 2000 kbps of bandwidth is expected to be delivered to this class in the
event of congestion, and a weight factor of 10 is used to calculate the average queue size. To avoid
congestion, WRED packet drop is used instead of tail drop. IP precedence is reset for levels 0 to 2. The
minimum threshold for IP precedence value 0 is 32, the maximum threshold is 256, and the
mark-probability denominator is 100. IP precedence values 1 and 2 have similar thresholds and
probability denominators.
Switch(config)# class-map c1
Switch(config-cmap)# match ip precedence 0 1 2
Switch(config-cmap)# exit
Switch(config)# policy-map policy10
Switch(config-pmap)# class c1
Switch(config-pmap-c)# bandwidth 2000
Switch(config-pmap-c)# random-detect precedence-based
Switch(config-pmap-c)# random-detect exponential-weighting-constant 10
Switch(config-pmap-c)# random-detect precedence 0 32 256 100
Switch(config-pmap-c)# random-detect precedence 1 64 256 100
Switch(config-pmap-c)# random-detect precedence 2 96 256 100
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
Switch(config-if)# service-policy output policy10
This example shows how to configure a VLAN-level policy called parent. It matches packets with VLAN
101 and associates a class-level child policy called policy1. The child policy matches two IP precedence
values in two classes. Thirty percentage of the available bandwidth is assigned to the gold class, 20
percent is assigned to the silver class, and 30 percent is assigned to vlan101. IP precedence-based WRED
is used as the drop policy. For the IP precedence 0 in the gold class, WRED randomly drops packets with
this IP precedence when the minimum threshold reaches 30. When the average queue size exceeds the
maximum threshold of 40, WRED drops all packets with IP precedence 0. The mark-probability
denominator is set to 10, which means that one out of every 10 packets is dropped when the average
queue is at the maximum threshold. The configuration has similar settings for IP precedence 3 in the
silver class. Note that when you configure the bandwidth command in a class policy, you also must
configure the bandwidth or shape policy-map class configuration command in the parent VLAN-level
policy.
Switch(config)# class-map gold
Switch(config-cmap)# match ip precedence 0
Switch(config-cmap)# exit
Switch(config)# class-map silver
Switch(config-cmap)# match ip precedence 3
Switch(config-cmap)# exit
Switch(config)# class-map vlan101
Switch(config-cmap)# match vlan 101
Switch(config-cmap)# exit
Switch(config)# policy-map policy1
Switch(config-pmap)# class gold
Switch(config-pmap-c)# bandwidth percent 30
Switch(config-pmap-c)# random-detect precedence-based
Switch(config-pmap-c)# random-detect precedence 0 30 40 10
Switch(config-pmap-c)# exit
Switch(config-pmap)# class silver
Switch(config-pmap-c)# bandwidth percent 20
Switch(config-pmap-c)# random-detect precedence-based
Switch(config-pmap-c)# random-detect precedence 3 28 35 10
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Catalyst 3750 Metro Switch Software Configuration Guide
26-96
78-15870-01

Advertisement

Table of Contents
loading

Table of Contents