Access Control Lists (ACLs)
Displaying ACL Data
Note
ProCurve (config)# show access-list config
ip access-list standard "50"
permit 10.128.100.10 0.0.0.0
permit 10.128.100.27 0.0.0.0
permit 10.128.80.14 0.0.0.0
exit
ip access-list standard "60"
deny 10.128.93.17 0.0.0.0
deny 10.28.93.25 0.0.0.0
permit 0.0.0.0 255.255.255.255
exit
ip access-list extended "110"
permit tcp 10.10.10.44 0.0.0.0 10.10.20.78 0.0.0.0 eq 23
deny ip 10.10.10.1 0.0.0.255 10.10.20.1 0.0.0.255
permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list extended "120"
permit tcp 10.10.20.100 0.0.0.0 10.10.30.55 0.0.0.0 eq 21
deny tcp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 eq 21
permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list extended "150"
permit tcp 10.10.20.100 0.0.0.0 10.10.10.1 0.0.0.255 eq 23
permit tcp 10.10.20.200 0.0.0.0 10.10.10.1 0.0.0.255 eq 23
exit
Figure 9-20. Example of an ACL Configured Syntax Listing
9-56
Notice that you can use the output from this command for input to an offline
text file in which you can edit, add, or delete ACL commands. Refer to "Editing
ACLs and Creating an ACL Offline" on page 9-60.
This information also appears in the show running display. If you executed
write memory after configuring an ACL, it appears in the show config display.
For example, with two ACLs configured in the switch, you will see results
similar to the following:
Display the ACL Assignments for an Interface
This command briefly lists the identification and type(s) of ACLs currently
assigned to a particular interface (one or more ports and/or trunks) in the
running-config file. (The switch allows up to one, inbound ACL assignment
per interface.)
Syntax: show access-list ports < interface >
List the ACLs assigned to interfaces in the running config file.
Need help?
Do you have a question about the 2610 and is the answer not in the manual?
Questions and answers