Configuring Cos Maps - Cisco 2950G 24 - Catalyst Switch Software Configuration Manual

Desktop switch
Hide thumbs Also See for 2950G 24 - Catalyst Switch:
Table of Contents

Advertisement

Configuring QoS
Switch(config)# access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)# class-map ipclass1
Switch(config-cmap)# match access-group 1
Switch(config-cmap)# exit
Switch(config)# policy-map flow1t
Switch(config-pmap)# class ipclass1
Switch(config-pmap-c)# police 5000000 8192 exceed-action dscp 10
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# service-policy input flow1t
This example shows how to create a Layer 2 MAC ACL with two permit statements and attach it to an
ingress interface. The first permit statement allows traffic from the host with MAC
address 0001.0000.0001 destined for the host with MAC address 0002.0000.0001.
Switch(config)# mac access-list extended maclist1
Switch(config-ext-mac)# permit host 0001.0000.0001 host 0002.0000.0001
Switch(config-ext-mac)# exit
Switch(config)# mac access-list extended maclist2
Switch(config-ext-mac)# permit host 0001.0000.0003 host 0002.0000.0003
Switch(config-ext-mac)# exit
Switch(config)# class-map macclass1
Switch(config-cmap)# match access-group name maclist1
Switch(config-cmap)# exit
Switch(config)# policy-map macpolicy1
Switch(config-pmap)# class macclass1
Switch(config-pmap-c)# set ip dscp 56
Switch(config-pmap-c)# exit
Switch(config-pmap)# class macclass2 maclist2
Switch(config-pmap-c)# set ip dscp 48
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# mls qos trust cos
Switch(config-if)# service-policy input macpolicy1

Configuring CoS Maps

This feature is available only if your switch is running the EI.
Note
This section describes how to configure the CoS maps:
All the maps are globally defined.
Catalyst 2950 Desktop Switch Software Configuration Guide
26-24
Configuring the CoS-to-DSCP Map, page 26-25
Configuring the DSCP-to-CoS Map, page 26-26
Chapter 26
Configuring QoS
78-14982-01

Advertisement

Table of Contents
loading

This manual is also suitable for:

Catalyst 2950

Table of Contents