Download  Print this page

Advertisement

IC-Link Version 2.8
User Manual
User Manual Release Date 11/2004

Advertisement

Table of Contents

   Related Manuals for Kyocera F-1000A

   Summary of Contents for Kyocera F-1000A

  • Page 1 IC-Link Version 2.8 User Manual User Manual Release Date 11/2004...
  • Page 2: Table Of Contents

    Resource Menu Add & Delete IC Link Project Resource Files ...Page 7 IC Link Project File Properties...Page 8 Tools Menu Printer Tools ...Page 9 Custom Tools...Page 10 Muti-Part Form Creator ...Page 11 EMCR Creator ...Page 14 KPDL Font Downloader...Page 19 LDFC Font Viewer ...Page 23...
  • Page 3 Forms, Program Data, Multi-Part Forms, EMCR Macros, Bitmap Image Macros, and JPEG Image Macros on Kyocera Printers. These Resources are defined and added into the IC Link Project Files and can be written to and stored on PC Memory Cards (Compact Flash Card and PCMCIA Cards) or the printer Hard Drive / Micro Drive. In...
  • Page 4 Creating an IC Link Project 1. From the IC Link menu bar select [File>Save Project As…]. 2. This will prompt you for a Folder location, Project File Name in the Save As dialogue box. 3. Once you have defined the IC Link Project File name, click on the Save button to save the IC Link Project File.
  • Page 5: Setting Preferences

    Global Options and File Mappings Default File Mapping List Description TrueType Font HP PCL EO Font HP Bitmap Portrait Font HP Bitmap Landscape Font Kyocera Bitmap Font PCL Macro PRESCRIBE Macro PRESCRIBE Macro Application Generated Form Program Data Extension Type...
  • Page 6: Project Menu

    Project Menu The Project Settings define the IC Card Image type and Capacities. The Project Settings can be accessed as follows: 1. From the IC Link menu bar select [Project>Settings…]. This will display the Project Settings dialogue box where the Image and Card Capacity settings are defined as follows: Image Settings •...
  • Page 7 Project Build is the action of building the Resource Files (fonts, macros, host-file forms, and program files) onto the Build Target in the printer which could be an IC Card in printer, Hard Disk / Micro Drive in printer, Export File for EPROM, or an Export File for JEIDA (PCMCIA) Card.
  • Page 8: Resource Menu

    Kyocera print system. Features such as Electronic Form overlays, Specialized Fonts, Multi-Part Forms, and Application Program Interfaces (API’s) can be enabled on the Kyocera print system. Resource files can be added or deleted from the IC Link Project file as follows: 1.
  • Page 9 Host-File Forms Properties – defines resource type, location, description, and size. Resource settings include Set form as default for power on. This setting sets the printer FRPO Interface Dependent Parameter I0 (partition name) to the name of the Resource file. This is useful for setting partition files to boot at power up for Universal Filter API’s, AMCR(Automatic) macros and EMCR (Cassette assigned) macros.
  • Page 10: Tools Menu

    CMCIA card – formats the PCMCIA card in the printer. In addition to the standard Printer Tools – you can also create your own Custom Printer Tools that can be customized to fit a specific IC Link Project File. 1. From the [Custom Macro Tools] under the Printer Tools dialogue box, select the [Add] button.
  • Page 11: Muti-part Form Creator

    Multi-Part Form Creator will build PRESCRIBE based macro files into a CCPY command. By means of the CCPY command, the Kyocera-Mita printers can print multiple copies from different cassettes when a print file is sent to the printer. Each printed page can utilize a different macro and cassette to apply different forms (Customer Copy, File Copy, Freight Copy).
  • Page 12 Data/Overlay – The overlay can be printed out separately or with the print data. Stack – the stack position of the printer can be defined. g. OK – will add the Cassette, Overlay, Resolution, Data/Overlay, and Stack settings to the Page.
  • Page 13 Tools Menu 5. After all the pages have been configured and created in the Multi-Part Form Creator, click on the “Add to project…” button. This will create two files called ccpy on.prn and ccpy off.prn which can be saved onto the local PC and added into the IC Link Project File under the “Host-File forms”...
  • Page 14 7. The ccpy on.prn and ccpy off.prn files are now located in the “Host-Files Forms” in the IC Link Project File now and ready to be built onto the target storage device of the printer (HDD, Microdrive, or Compact Flash Card). These files are the “ON” and “OFF” triggers for the Multi-Part Form feature.
  • Page 15 “ON” to start the Multi-Part Form Macro. 13. Send your print data to the printer. The Multi-Part Form will be active for any print jobs sent to the printer. NOTE: Using Logical Printer Ports, it is possible to accommodate multiple Multi-Part Forms projects on one printer or to dedicate to one specific Printer Port using a PRESCRIBE RWER command to trigger the ccpy on.prn at the...
  • Page 16: Emcr Creator

    Tools Menu By means of the PRESCRIBE EMCR command, the Kyocera Mita printers can have PRESCRIBE based macros assigned to a cassette, so that when print jobs are pulled from that cassette the macro will overlay with the print data. Each cassette can use a macro to apply a different form. Using EMCR is similar in concept to having pre- printed materials in the cassettes, less the expense of the pre-printed materials.
  • Page 17 Tools Menu 3. With the EMCR Creator active you can begin to configure your EMCR Macro by selecting the Paper Source, clicking on the “Assing Macro / modify…” button and defining the following parameters in the “Macro to Paper Source” dialogue box : a.
  • Page 18 Tools Menu 5. After all the pages have been defined in the EMCR Creator, click on the [Add to project…] button. This will create two files called ccpy on.prn and ccpy off.prn which can be saved onto the local PC and added into the IC Link Project File under the “Host-File forms”...
  • Page 19 7. The emcr on.prn and emcr off.prn files are now located in the “Host-Files Forms” of the IC Link Project File and are ready to be built onto the target storage device of the printer (HDD, Microdrive, or Compact Flash Card). These files are the “ON” and “OFF” triggers for the EMCR Macro feature.
  • Page 20 Send to Printer – sends the project file to the printer. 10. After all the Project Build settings have been completed, click on the [Send to printer] button, a WARNING message will display warning the Format of the Compact Flash Card will erase all data on that Compact Flash Card.
  • Page 21: Kpdl Font Downloader

    KPDL Font Downloader is a PostScript font tool that has been built into IC Link. It gives you the ability to download PostScript (*.pfb) fonts to the Kyocera printer (the printer must support KPDL). Like the Bitmap fonts mentioned under the “Resource Menu” on page 6, the PostScript fonts can also be saved to a Compact Flash Card and the Printer HDD or Micro Drive.
  • Page 22 3. Select the PostScript fonts you wish to download to the printer and click on the OK button. This will add the fonts to the KPDL Font Downloader, and populate the font information field with the Font Name, Target Font File, Local File Path and the Font File Size.
  • Page 23 Medium (Compact Flash Card or Hard Disk / Micro Drive). 6. To confirm that all the selected fonts have been properly loaded to the printer, click on the Print font list. A User Defined Scalable Font List will print out at the printer. The list should contain all the fonts loaded with the KPDL Font Downloader (See the next page for an example of the Font List).
  • Page 24 IC Link for Windows Tools Menu KPDL Font Downloader (continued) Sample of User Defined Scaleable Font List {PAGE }...
  • Page 25: Ldfc Font Viewer

    LDFC Font Viewer LDFC Font Viewer is a tool built into IC Link for viewing the Kyocera created LDFC Bitmap fonts. Historically these types of fonts would have been created using a legacy Kyocera Utility called Font Logo Master. This tool would be more commonly used for legacy Kyocera Bitmap Fonts.
  • Page 26 Tools Menu LDFC Font Viewer (continued) 2. With the LDFC Font Viewer running, select [File>Open], and browse to your folder location which has the Kyocera Bitmap Fonts. Select the Font file (*.LDF) and click on the Open button. {PAGE }...
  • Page 27 LDF font. NOTE: The LDFC Font Viewer will only display the Font Status Page for a Kyocera Bitmap font with the LDF font extension. To create a Font Status Page for standard Bitmap fonts please see the following pages under the Font Status Page title.
  • Page 28: Font Status Page (!r! Fsts;exit;)

    IC Link for Windows Font Status Page A Bitmap Font Status Page can be printed from the printer, by issuing the following PRESCRIBE command to the !R! FSTS; EXIT; printer: This command will instruct the print controller to print a Font Status Page of the active bitmap font, and will represent the font characteristics with a table of mapped bits for each character used in the font.
  • Page 29: Prescribe Samples

    PRESCRIBE Samples is a tool for viewing PRESCRIBE commands, the command format and parameters. Each of the PRESCRIBE commands has a working template which can be sent to any of the Kyocera printers to demonstrate the command’s function. With the PRESCRIBE Samples module running you can view all the PRESCRIBE Commands which are arranged into separate folders by category.
  • Page 30 Prescribe Command Search – will search for a particular PRESCRIBE command. • Select Printer / Send to printer – allows the user to define the target printer and to send the PRESCRIBE Sample to the printer. NOTE: The PRESCRIBE Sample for Text Command can be copied and pasted into Text Pad or Notepad to use as a template to customize the command syntax to meet your requirement.
  • Page 31: Ic Link Image Converter

    IC Link can be used as a method to create simple PRESCRIBE based forms from scanned images. Generally the *.BMP converted image is used for Kyocera monochrome printers and the *.JPEG converted image can be used for Kyocera color printers.
  • Page 32 This will create a Macro Icon under the [Macro] tab of the IC Link Project File. 4. After the macro file has been added to the IC Link Project File, then you can build it to the Printer following the instructions for under the Project Menu – Project Build and Project Settings on page 6 of this document.
  • Page 33 Orientation – Defines page orientation. If left blank, the page orientation will follow what is set on the printer. Output Width and Output Height - Defines the Image Width and Height. It is not necessary to define any values here, as the Width and...
  • Page 34 Printer by selecting [Project>Build]. This will launch the Project Build dialogue box and you can Configure the IC Memory Card Settings and Select the target printer to build the IC Link Project File. Additional details on Project Builds can be referenced on page 6 of this User Guide.
  • Page 35 In each case a PRESCRIBE Macro is required to be built onto the printer. The following instructions outline the process of creating the trigger to initiate or call these macros using the Kyocera KX Print Driver Prologue / Epilogue feature as follows: CALL Macro / AMCR Macro 1.
  • Page 36 5. Click on the PDL button to display the PDL settings of the print driver. 6. Using the drop down menu under the Printer Description Language, select PCL 5e and click OK. 7. Click OK again to close the print driver properties and set the PDL change.
  • Page 37 KX Print Driver Prologue / Epilogue Feature Initiating PRESCRIBE Macros from Microsoft Windows (continued) 7. Open the Print Driver properties again and click on the General tab. 8. Click on the Printing Preferences button. This will display the print driver printing preferences. 9.
  • Page 38 KX Print Driver Prologue / Epilogue Feature Initiating PRESCRIBE Macros from Microsoft Windows (continued) 10. With the Prologue / Epilogue feature enabled, select the Add button. 11. Browse to the Notepad file with the PRESCRIBE Call statement for the desired macro, select it and click on the Open button.
  • Page 39 As there are other considerations for printing environments, there are also other methods for calling or initiating a PRESCRIBE based macro. To learn more about these methods, please contact your Authorized Kyocera Mita Dealer. IC Link for Windows...

Comments to this Manuals

Symbols: 0
Latest comments: