Configuring Physical Layer 3 Interfaces - Cisco 4500M Software Manual

Software guide
Table of Contents

Advertisement

Chapter 23
Configuring Layer 3 Interfaces
To configure physical Layer 3 interfaces, perform this task:
Command
Step 1
Switch(config)#ip routing
Step 2
Switch(config)# interface {fastethernet |
gigabitethernet | tengigabitethernet} slot / port }
| {port-channel port_channel_number }
Step 3
Switch(config-if)#no switchport
Step 4
Switch(config-if)# ip address ip_address
subnet_mask
Step 5
Switch(config-if)# no shutdown
Step 6
Switch(config-if)# end
Step 7
Switch# copy running-config startup-config
Step 8
Switch# show interfaces [ type slot/interface ]
Switch# show ip interfaces [ type slot/interface ]
Switch# show running-config interfaces [ type
slot/interface ]
This example shows how to configure an IP address on Fast Ethernet interface 2/1:
Switch# configure terminal
Enter configuration commands, one per line.
Switch(config)# ip routing
Switch(config)# interface fastethernet 2/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.1.1.1 255.255.255.248
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch#
This example uses the show running-config command to display the interface IP address configuration
of Fast Ethernet interface 2/1:
Switch# show running-config
Building configuration...
!
interface FastEthernet2/1
no switchport
ip address 10.1.1.1 255.255.255.248
!
...
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
OL-6696-01

Configuring Physical Layer 3 Interfaces

Purpose
Enables IP routing (Required only if disabled.)
Selects an interface to configure.
Converts this port from physical Layer 2 port to physical
Layer 3 port.
Configures the IP address and IP subnet.
Enables the interface.
Exits configuration mode.
Saves your configuration changes to NVRAM.
Verifies the configuration.
End with CNTL/Z.
Software Configuration Guide—Release 12.2(25)EW
23-5

Advertisement

Table of Contents
loading

This manual is also suitable for:

4500 series

Table of Contents