Configuring Cbwfq And Dscp-Based Wred - Cisco Catalyst 3750 Software Configuration Manual

Metro switch
Hide thumbs Also See for Catalyst 3750:
Table of Contents

Advertisement

Chapter 26
Configuring QoS
This example shows how to create a VLAN-level policy-map called log-policy. It matches packets with
VLAN 203 and associates a class-level child policy called cls-policy. The child policy matches packets
with a CoS value of 2, sets 50 percent as the available bandwidth for this class, and sets 2000 packets as
the maximum threshold for tail drop. Packets are queued until the maximum threshold is exceeded, and
then all the packets are dropped. Note that when you configure the bandwidth command in a class
policy, you also must configure the bandwidth or shape policy-map class configuration command in the
parent VLAN-level policy.
Switch(config)# class-map cls-class
Switch(config-cmap)# match cos 2
Switch(config-cmap)# exit
Switch(config)# class-map log-class
Switch(config-cmalp)# match vlan 203
Switch(config-cmap)# exit
Switch(config)# policy-map cls-policy
Switch(config-pmap)# class cls-class
Switch(config-pmap-c)# bandwidth percent 50
Switch(config-pmap-c)# queue-limit 2000
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# policy-map log-policy
Switch(config-pmap)# class log-class
Switch(config-pmap-c)# bandwidth percent 50
Switch(config-pmap-c)# service-policy cls-policy
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet1/1/2
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
Switch(config-if)# service-policy output log-policy

Configuring CBWFQ and DSCP-Based WRED

CBWFQ creates a queue for every class for which a class map is defined. Packets satisfying the match
criteria for a class accumulate in the queue reserved for the class until they are sent, which occurs when
the queue is serviced by the fair queue process. When the maximum packet threshold that you defined
for the class is reached, any more packets destined for the class queue are dropped according to the tail
drop or the WRED mechanism.
WRED reduces the chances of tail drop by selectively dropping packets when the port begins to show
signs of congestion. By dropping some packets early rather than waiting until the queue is full, WRED
avoids dropping large numbers of packets at once.
When a packet arrives and WRED is enabled, these events occur:
78-15870-01
The average queue size is calculate based on the previous average and the current size of the queue.
The average queue-size calculation is affected by the exponential weight constant setting in the
random-detect exponential-weight-constant policy-map class configuration command.
If the average queue size is less than the minimum queue threshold, the arriving packet is queued.
The minimum queue threshold is configured through the min-threshold option in the random-detect
dscp policy-map class configuration command.
Catalyst 3750 Metro Switch Software Configuration Guide
Configuring Hierarchical QoS
26-89

Advertisement

Table of Contents
loading

Table of Contents