Cisco WS-C3550-12G Software Configuration Manual page 488

Multilayer switch
Hide thumbs Also See for WS-C3550-12G:
Table of Contents

Advertisement

Chapter 20
Configuring QoS
Configuring QoS
This example shows how to create a policy map and attach it to an ingress interface. In the configuration,
the IP standard ACL permits traffic from network 10.1.0.0. For traffic matching this classification, the
DSCP value in the incoming packet is trusted. If the matched traffic exceeds an average traffic rate
of 48000 bps and a normal burst size of 8000 bytes, its DSCP is marked down (based on the
policed-DSCP map) and sent:
Switch(config)# access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)# class-map ipclass1
Switch(config-cmap)# match access-group 1
Switch(config-cmap)# exit
Switch(config)# policy-map flow1t
Switch(config-pmap)# class ipclass1
Switch(config-pmap-c)# trust dscp
Switch(config-pmap-c)# police 48000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# service-policy input flow1t
This example shows how to create a policy map and attach it to an ingress interface. In the configuration,
the IP extended ACL permits Transmission Control Protocol (TCP) traffic with an IP precedence of 4
from any host destined for the host at 224.0.0.5. For traffic matching this classification, the DSCP value
in the incoming packet is set to 63.
Switch(config)# access-list 104 permit tcp any host 224.0.0.5 precedence 4
Switch(config)# policy-map ip104
Switch(config-pmap)# class ipclass104 access-group 104
Switch(config-pmap-c)# set ip dscp 63
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# service-policy input ip104
This example shows how to create a Layer 2 MAC ACL with two permit statements and attach it to an
ingress interface. The first permit statement allows traffic from the host with MAC
address 0001.0000.0001 destined for the host with MAC address 0002.0000.0001. The second permit
statement allows only Ethertype XNS-IDP traffic from the host with MAC address 0001.0000.0002
destined for the host with MAC address 0002.0000.0002.
Switch(config)# mac access-list extended maclist1
Switch(config-ext-mac)# permit 0001.0000.0001 0.0.0 0002.0000.0001 0.0.0
Switch(config-ext-mac)# permit 0001.0000.0002 0.0.0 0002.0000.0002 0.0.0 xns-idp
Switch(config-ext-mac)# exit
Switch(config)# mac access-list extended maclist2
Switch(config-ext-mac)# permit 0001.0000.0003 0.0.0 0002.0000.0003 0.0.0
Switch(config-ext-mac)# permit 0001.0000.0004 0.0.0 0002.0000.0004 0.0.0 aarp
Switch(config-ext-mac)# exit
Switch(config)# class-map macclass1
Switch(config-cmap)# match access-group maclist1
Switch(config-cmap)# exit
Switch(config)# policy-map macpolicy1
Switch(config-pmap)# class macclass1
Switch(config-pmap-c)# set ip dscp 63
Switch(config-pmap-c)# exit
Switch(config-pmap)# class macclass2 maclist2
Switch(config-pmap-c)# set ip dscp 45
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# mls qos trust cos
Switch(config-if)# service-policy input macpolicy1
Catalyst 3550 Multilayer Switch Software Configuration Guide
20-36
78-11194-03

Hide quick links:

Advertisement

Table of Contents
loading

This manual is also suitable for:

Catalyst 3550

Table of Contents