Casio PROGRAM-LINK FA-124 User Manual

Ver. 2.00
Hide thumbs

Advertisement

Quick Links

PROGRAM-LINK
FA-124
User's Guide
CASIO Worldwide Education Website
http://edu.casio.com
CASIO EDUCATIONAL FORUM
http://edu.casio.com/forum/
RJA510188-4
Ver. 2.00
E

Advertisement

loading

  Also See for Casio PROGRAM-LINK FA-124

  Related Manuals for Casio PROGRAM-LINK FA-124

  Summary of Contents for Casio PROGRAM-LINK FA-124

  • Page 1 PROGRAM-LINK FA-124 User’s Guide CASIO Worldwide Education Website http://edu.casio.com CASIO EDUCATIONAL FORUM http://edu.casio.com/forum/ RJA510188-4 Ver. 2.00 ™...
  • Page 2 Note Display examples shown in this User’s Guide are intended for illustrative purposes only. The actual text and values that appear on display may differ from the examples shown in this User’s Guide. VS-FlexGrid Pro 8.0J Copyright © 2001-2007 ComponentOne LLC.
  • Page 3 • You can use FA-124 to develop programs using the same commands as those available on the CASIO Graphic Scientific Calculator. You can store your programs on your computer, and use the FA-124’s data communication functions to transfer them to your calculator when you need them.
  • Page 4 • The terms “FA-124” and “this software” as used in this manual refer to the FA-124 Ver. 2.00 software. • The term “calculator” as used in this manual refers to your CASIO Graphic Scientific Calculator. • This manual explains only the procedures required to operate the FA-124 application software. It assumes that you are already familiar with the following computer operations.
  • Page 5 CFX-9850G fx-9750G CFX-9850G PLUS CFX-9850Ga PLUS CFX-9850GB PLUS • fx-7400G Series fx-7450G fx-7400G PLUS In addition, the following CASIO Graphic Scientific models can exchange data with the above models. fx-7700GB fx-8700GB fx-7700GE fx-7700GH fx-9700GE fx-9700GH * All of the fx-9860G Series calculator operations shown in this manual are performed using the fx-9860G SD/fx-9860G.
  • Page 6 System Requirements Operating Systems: Windows * Operation on a computer running Windows not supported. * For Windows Vista The 64-bit version is not supported. Computer: Computer with one of the Windows (Excluding computers with an upgraded operating system and self-built computers.) Account Type: Administrator...
  • Page 7: Table Of Contents

    Contents 1. Installing the Software ... E-6 Installing ... E-6 Uninstalling ... E-11 2. Connecting the Calculator to Your Computer ... E-12 3. Data Transfer between a Computer and fx-9860G Series/ fx-9750GII/fx-7400GII ... E-24 Toolbar Buttons and Icons ... E-25 Menu Commands and Icons ...
  • Page 8: Installing The Software

    It is strongly recommended that you exit all Windows Programs before running the Install Wizard. k To install FA-124 Open the [FA-124] folder. Double-click “CASIO FA-124” or “CASIO FA-124.exe”. • This displays a language selection menu. • The option you select here specifies the language of the screen text that appears during installation.
  • Page 9 Select a language and then click the [OK] button. Click the [Next] button. • This displays the end user license agreement (EULA). • Selecting English, French, or German in step 3 above will cause the EULA to appear in the selected language.
  • Page 10 1. Installing the Software Carefully read the EULA. If you agree to be bound by the terms and conditions of the EULA, choose “I accept the terms...”, and then click [Next]. • If you do not want to agree, choose “I do not accept the terms...” and then click [Cancel] to exit the installation operation.
  • Page 11 Perform either of the two following steps to specify the installation drive and folder. • To use the default settings Simply click the [Next] button. • To specify a different folder Click the [Change…] button. Select the folder you want and then click [Next]. Click the [Install] button to start the installation.
  • Page 12 1. Installing the Software • If your computer is running Windows Vista a. The dialog box shown below will appear when installation starts. Windows Vista ® : Click “Allow”. ® Windows 7: Click “Yes”. b. The dialog box shown below will appear if the USB driver is not installed on your computer.
  • Page 13: Uninstalling

    To uninstall Display the Windows Control Panel. Click [Add/Remove Programs]. In the list of applications on the dialog box that appears, select “CASIO FA-124”. Click the [Add/Remove] button to start a program maintenance wizard. Click the [Yes] button. • This completes the uninstall procedure.
  • Page 14: Connecting The Calculator To Your Computer

    2. Connecting the Calculator to Your Computer k To connect the calculator to your computer with the USB cable Important! • Be sure to install the FA-124 before you connect the calculator to your computer. Connecting before you install the FA-124 can result in improper operation. Connect the USB cable that comes with the calculator or with the FA-124 USB to your computer.
  • Page 15 u Windows ® XP Users After installing the FA-124, perform the following steps to install the USB driver on your computer. Connecting the calculator to a computer running Windows to appear on your computer display. Select “Install the software automatically (Recommended)” and then click [Next]. 2.
  • Page 16 2. Connecting the Calculator to Your Computer Though a message appears to let you know that the software has not passed the “Windows Logo Test”, there is no need for concern. Simply click [Continue Anyway] and proceed with installation. Click [Finish]. k To connect the calculator to your computer with the SB-88 cable Note •...
  • Page 17 ® Windows Connecting the calculator to your computer will cause the screen shown below to appear on your computer. Select “Install from a list or specific location (Advanced)” and then click [Next]. 2. Connecting the Calculator to Your Computer E-15...
  • Page 18 2. Connecting the Calculator to Your Computer Select “Include this location in the search:” and then enter “E:\USB2KXP” (assuming the name of your CD-ROM drive is E:). • You also could click [Browse] and select the USB driver on the dialog box that appears. Click [Next].
  • Page 19 ® Windows Vista Connecting the calculator to your computer will cause the screen shown below to appear on your computer. Click “Locate and install driver software (recommended)”. 2. Connecting the Calculator to Your Computer E-17...
  • Page 20 2. Connecting the Calculator to Your Computer Click “Don’t search online”. Click “Browse my computer for driver software (advanced)”. Enter “E:\USB2KXP” (assuming the name of your CD-ROM drive is E:). • You also could click [Browse] and select the USB driver on the dialog box that appears. E-18...
  • Page 21 Click [Next]. Click “Install this driver software anyway”. 10 . Click [Close]. 2. Connecting the Calculator to Your Computer E-19...
  • Page 22 2. Connecting the Calculator to Your Computer ® Windows On the Start menu, right-click Computer and then select Properties. • The screen show below will appear on your computer. Click “Device Manager”. E-20...
  • Page 23 Right-click “Unknown device” under “Other devices” and then select “Properties”. Click [Update Driver]. 2. Connecting the Calculator to Your Computer E-21...
  • Page 24 2. Connecting the Calculator to Your Computer Click “Browse my computer for driver software”. Enter “E:\USB2KXP” (assuming the name of your CD-ROM drive is E:). • You also could click [Browse] and select the USB driver on the dialog box that appears. Click [Next].
  • Page 25 10 . Click “Install this driver software anyway”. 11 . Click [Close]. 2. Connecting the Calculator to Your Computer E-23...
  • Page 26: Data Transfer Between A Computer And Fx-9860G Series

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G II /fx-7400G II On your computer’s desktop, double-click “FA-124”. • This starts up FA-124. Select [Tool] - [Model Type] - [fx-9860G Series/fx-9750G • You also can select [Tool] - [Model Type] - [GRAPH95/85/75/35+]. Select [Link] - [Communications].
  • Page 27: Toolbar Buttons And Icons

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G /fx-7400G Toolbar Buttons and Icons The following describes FA-124 toolbar buttons and icons. — Establishes a connection between your calculator and FA-124. — Disconnects your calculator from the FA-124. — Copies the currently selected folder(s) or file(s). —...
  • Page 28 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G /fx-7400G — Icon for folders and files in the flash image. (Can be selected with fx-9860G Series only.) — Icon for data groups and files in the memory image. — Icon for a folder. —...
  • Page 29: Menu Commands And Icons

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G /fx-7400G Menu Commands and Icons The following describes the shortcut menus that appear when you right-click with the mouse. k Right-clicking [User Name] (Calculator) • Collapse/Expand — Collapses/expands data groups. • Copy — Copies the currently selected data group(s), folder(s) or file(s). •...
  • Page 30 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G k Right-clicking (FA-124) • Export — Exports the files in the selected folder to an external file. • Import — Imports an external file to an image. • Copy — Copies the currently selected folder. •...
  • Page 31: Transferring Data From The Calculator To A Computer

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G k Right-clicking FA-124 • Expand/Collapse — Expands/Collapses the currently selected flash or memory image. • Add New Image — Adds a new image. • Insert Existing Image — Inserts an existing image. k Right-clicking •...
  • Page 32: Using Fa-124

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G k To configure the calculator for data transfer with the SB-88 cable Connect the SB-88 cable. From the main menu, enter the LINK mode and then press 2(RECV). • This will display the “Receiving...” screen. Using FA-124 The following procedures explain how to perform various data transfer and other operations using FA-124.
  • Page 33 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G After the connection is established, the Calculator window will show data groups and data, while the FA-124 window will show flash images and memory images. • On the Calculator window toolbar, click memory data.
  • Page 34 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G k To transfer a data group from the calculator to a computer Start up FA-124 and establish a connection with your calculator. On the Calculator window, select the data group you want to transfer. •...
  • Page 35 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Select the data you want to transfer. • To select multiple data items, hold down the computer keyboard’s [Ctrl] key as you click each one. Use your mouse to drag the selected data to the FA-124 window memory image to transfer it. •...
  • Page 36 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Double-click the data group to expand it. Select the file you want to transfer. • To select multiple files, hold down the computer keyboard’s [Ctrl] key as you click each one. Use your mouse to drag the selected file to the Calculator window icon to transfer it.
  • Page 37 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G If you want to transfer other files, repeat steps 3 and 5. After you are finished, terminate the connection between your calculator and computer. k To create a new folder On the Calculator window (storage memory only) or the FA-124 window, click the tool bar button.
  • Page 38: Batch Transferring Files

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G On the confirmation dialog box that appears, click [OK] to delete or [Cancel] to cancel. k To terminate the connection between your calculator and FA-124 After data transfer is complete, click Your computer screen will show this.
  • Page 39: Adding A Flash Image Or Memory Image

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Adding a Flash Image or Memory Image Use the procedure below when you want to add a flash image or memory image to the FA-124 window. The following procedure shows how to add a flash image. The procedure for adding a memory image is virtually identical.
  • Page 40 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Right-click with the mouse. On the shortcut menu that appears, select [Export]. • Flash image: The dialog box shown below appears. Select the save destination directory, and then click [OK]. The file is saved using the same name as the flash image. •...
  • Page 41: Importing A Flash Image Or Memory Image

    3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Importing a Flash Image or Memory Image Use the FA-124 to import a flash image or memory image stored in a file on a computer’s hard disk. Right-click with your mouse. On the shortcut menu that appears, select [Insert Existing Image].
  • Page 42 3. Data Transfer between a Computer and fx-9860G Series/fx-9750G Right-click with your mouse. On the shortcut menu that appears, select [Import]. On the file dialog box, select the file you want to import, and then click [Open]. • This will add the imported file data to the flash image or memory image. Note •...
  • Page 43: Data Transfer Between A Computer And Algebra Fx Series Or Fx-7400G/Cfx-9850G Series

    Input Replay Output Replay Equation Data from an older model CASIO Graphic Scientific Calculator is converted to CFX-9850G/fx-7400G Series format data. u Back-up file This file contains the data produced when you back up all of the data in calculator memory.
  • Page 44: File Transfer

    4. Data Transfer between a Computer and ALGEBRA FX Series or fx-7400G/CFX-9850G Series Note • Graphic files saved as the above file format cannot be opened using FA-124. File Transfer The procedures described here can be used to upload calculator data to your computer, and to download programs and data from your computer to your calculator.
  • Page 45 4. Data Transfer between a Computer and ALGEBRA FX Series or fx-7400G/CFX-9850G Series k k k k k Transferring files from your calculator to your computer Select [Link] - [Receive] on the computer screen. Select the calculator data you want and then send it. Example: Use the following procedure to send data from the ALGEBRA FX.
  • Page 46 4. Data Transfer between a Computer and ALGEBRA FX Series or fx-7400G/CFX-9850G Series Save the data as a file. Select [File] - [Save]. Specify a file name and click [OK] to save it as a catalog file. Note • Selecting [File] - [Save] displays a dialog box you can use to specify the file name, drive, and directory.
  • Page 47: Back-Up Data Transfer

    4. Data Transfer between a Computer and ALGEBRA FX Series or fx-7400G/CFX-9850G Series Select [Link] - [Transmit]. • Double check to make sure that both units are set up correctly for data transfer and then click [OK]. • Data transfer starts at this time, with its progress indicated by a dialog box on the computer screen.
  • Page 48: Data Editing

    5. Data Editing Creating a New Catalog File (ALGEBRA FX, CFX-9850G, fx-7400G Series only) Select [File] - [New] - [Model Type], and then on the sending unit select [Model Type]. Input data to create a new program or copy (or move) data from another catalog window. •...
  • Page 49: Displaying, Editing, And Printing Items

    Double-click on the item to launch the program editor. Input the contents of the program. • See “8. Program Editor” for details on inputting program contents. Select [File] - [Close] to quit the program editor. Select [File] - [Save] to save the catalog file. Note •...
  • Page 50: Deleting, Copying, And Moving Groups And Items

    5. Data Editing Deleting, Copying, and Moving Groups and Items k k k k k To delete a group and item Select the group and item to be deleted and then select [Edit] - [Delete], or press the [Delete] key. k k k k k To copy a group and item to another catalog file Select the group and item to be copied and then select [Edit] - [Copy].
  • Page 51: Data Conversion

    6. Data Conversion • On the fx-9860G Series calculator, you can convert between List, File, Matrix, and Spreadsheet data and csv format data. • On an ALGEBRA FX, CFX-9850G, fx-7400G Series calculator, you can convert between List, File, and Matrix data and csv format data. •...
  • Page 52 6. Data Conversion k To convert csv data to calculator data Select [File] - [CSV-Load from CSV]. Select the csv data you want to convert. Select the type of calculator data you want to convert to. • When converting to fx-9860G Series Spreadsheet data, input up to eight characters for the file name.
  • Page 53 • This will displays a file name input dialog box. Type in the file name, and then click [OK]. • The converted catalog file (with extension “.cat”) will be stored at My Documents\Casio\FA- 124 on your computer’s hard disk. 6. Data Conversion...
  • Page 54 6. Data Conversion When converting to ALGEBRA FX Series: select [Tool] - [Model Type] - [ALGEBRA FX series]. When converting to CFX-9850G/fx-7400G Series: select [Tool] - [Model Type] - [fx-7400G/ CFX-9850G series]. Select [File] - [Open], and then open the converted catalog file. (See “Transferring files from your computer to your calculator”...
  • Page 55 Type in the file name, and then click [OK]. • The converted image file (with extension “.g1r”) will be stored at My Documents\Casio\FA-124 on your computer’s hard disk. Select [Tool] - [Model Type] - [fx-9860G Series/fx-9750G • You also can select [Tool] - [Model Type] - [GRAPH95/85/75/35+].
  • Page 56: Screen Capture

    7. Screen Capture The screen image of the calculator can be captured as a bit pattern and transferred to your computer. Note • For details on how to operate your calculator for screen capture, see the section of the calculator’s User’s Guide titled “Data Communications.” Capturing a Screen to Your Computer u fx-9860G Series, fx-9750G Connect the USB cable.
  • Page 57 u ALGEBRA FX Series Set up the calculator to send a screen shot to a computer. • Use the calculator’s LINK mode set up (u3(SET UP)) to specify Direct (direct send) for the H-Copy item. On the calculator, display the screen you want to send to the computer. On the FA-124 menu bar, select [Link] - [Screen Capture].
  • Page 58: Displaying And Printing A Captured Screen Image

    7. Screen Capture Displaying and Printing a Captured Screen Image k To display a captured screen image Select [File] - [Open] and open the image file to display the image. k To print a captured screen image While the image is on the display, select [File] - [Print]. Specify the printer, print options, number of copies, and enlargement factors, and then start the printing.
  • Page 59: Program Editor

    8. Program Editor The program editor lets you edit the contents of programs. Launching the Program Editor Create a new program or select an existing program to launch the program editor. u Command Input You can input commands using any one of the three following methods. •...
  • Page 60: Data Transfer With An Old Model Calculator

    9. Data Transfer with an Old Model Calculator Using this software to transfer data to the computer from an older model calculator automatically converts the data to the format used by fx-9860G Series/fx-9750G on disk. • Old Model Caluculator fx-7700GB CFX-9800G fx-8700GB fx-7700GE...
  • Page 61: Installing An Add-In

    10. Installing an Add-in fx-9860G Series supports installation of the three types of add-ins described below. • Add-In Applications: You can install new applications as required. • Add-In Languages: You can install languages for on-screen messages. • Add-In Menus: You can install application menus in various languages. The procedure for installing an add-in the identical to the normal file import operation.
  • Page 62 10. Installing an Add-in Select the file you want to install, and then click [Open]. • This will cause the file to appear on the FA-124 window. Drag the file and drop it into the • This will install the add-in on the calculator. k k k k k To uninstall an add-in •...
  • Page 63 CASIO COMPUTER CO., LTD. 6-2, Hon-machi 1-chome Shibuya-ku, Tokyo 151-8543, Japan SA1203-G...