Cisco 800 Design Manual page 32

Fast step software design guide
Hide thumbs Also See for 800:
Table of Contents

Advertisement

Chapter 3
Template File Development
Example TPL File
!
hostname testhost
clock timezone GMT 0
!
enable secret secret
enable password password
!
username <USERNAME, "Username of ISDN Router", String, "Username">-isdn password x123abcd
isdn switch-type basic-net3
isdn tei-neg first
!
interface Ethernet0
ip address <E0_IP, "IP Address for Ethernet", IPAddress, "IP Addresses">
ip helper-address 144.254.44.12
!
interface BRI 0
ip unnumbered e0
encapsulation ppp
bandwidth 128
dialer idle-timeout 90
dialer wait-for-carrier-time 100
dialer map ip 171.68.125.229 name <USERNAME>-isdn 01818319036
!
dialer hold-queue 20
dialer load-threshold 80
dialer-group 1
ppp authentication chap
ppp multilink
!
ip route 0.0.0.0 0.0.0.0 171.68.125.229
access-list 101 deny tcp any any eq 123
access-list 101 deny udp any any eq ntp
access-list 101 deny udp any any eq 20
access-list 101 deny igmp any any
access-list 101 permit ip any any
dialer-list 1 list 101
!
line con 0
exec-timeout 0 0
password xxx123
login
line vty 0 4
password xxx123
login
!
end
Once entered, the values of the variables can be reused. For example:
username <USERNAME, "Username of ISDN Router", String, "Username">-isdn password x123abcd
...
dialer map ip 171.68.125.229 name <USERNAME>-isdn 01818319036
Cisco 800 Fast Step Software Design Guide
3-4
OL-10373-02

Advertisement

Table of Contents
loading

Table of Contents