Download  Print this page

Troubleshooting Guide - Kenwood BLP60 Manual

Hide thumbs

Advertisement

Table of Contents

troubleshooting guide

Problem
The Blender will not
operate.
Power On Light flashing
slowly.
(BLP61/BLM61 only)
BLP61/BLM61 Blender not Goblet fitted and speed
operating but Power On
and programme button
lights on.
Power on light flashing
rapidly (BLP61/BLM61 only) from the power unit
Programme buttons not
operating
Blender leaking from blade Seal missing.
assembly.
Blender seal missing from
blade unit when removed
from packaging.
If none of the above solve the problem see "Service & Customer Care".
Cause
No Power/Power On
Light not illuminated.
Blender not assembled
correctly.
The blender has
been left plugged in and
in the 'on' position for
more than 15 minutes
and has gone into
standby mode.
control turned to "on" but
speed or programme
not selected.
The goblet is removed
without turning the speed and reselect a
control to "O" OFF.
Programme buttons will
not operate unless the
speed control is turned to select the required
the "on" position first.
Seal incorrectly fitted.
Seal damaged.
The seal is packed
pre-fitted to the blade
unit.
12
Solution
Check blender
plugged in.
Check blade unit is
fully tightened to
the goblet.
Turn the speed
control to the
"O" OFF position,
wait 5 seconds and
then turn to "on" to
reset.
Either select a speed
manually or press
one of the
programme buttons.
Turn the speed
control to "O" OFF
speed.
Turn the speed
control to "on" and
programme.
Check seal is fitted
correctly and not
damaged. To obtain
a replacement seal
see "service &
customer care".
Unscrew goblet and
check that seal is
fitted to blade unit.
To obtain a
replacement seal
see "service &
customer care".

Hide quick links:

Advertisement

Table of Contents
loading

  Also See for Kenwood BLP60

This manual is also suitable for:

Blp61Blm60Blm61